Author Topic: 1.5.5 minor issue/bug  (Read 2167 times)

Offline Mody

  • Newbie
  • *
  • Posts: 2
1.5.5 minor issue/bug
« on: July 19, 2014, 12:52:06 AM »
Hey, I couldn't find a subforum for the Minecraft 1.5.5 plugin, so i've left this here in the 1.5 subforum instead if that's fine.


Every so often, about 2-30 minutes, the plugin generates these errors:



[20:52:45] [Server thread/WARN]: [Hive365] Task #765984 for Hive365 v1.5.5 generated an exception
java.lang.NullPointerException
   at net.keiaxx.h365.MainBot$1.run(MainBot.java:254) ~[?:?]
   at org.bukkit.craftbukkit.v1_7_R3.scheduler.CraftTask.run(CraftTask.java:58) ~[minecraft_server.jar:git-Spigot-1496]
   at org.bukkit.craftbukkit.v1_7_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:345) [minecraft_server.jar:git-Spigot-1496]
   at net.minecraft.server.v1_7_R3.MinecraftServer.v(MinecraftServer.java:635) [minecraft_server.jar:git-Spigot-1496]
   at net.minecraft.server.v1_7_R3.DedicatedServer.v(DedicatedServer.java:283) [minecraft_server.jar:git-Spigot-1496]
   at net.minecraft.server.v1_7_R3.MinecraftServer.u(MinecraftServer.java:583) [minecraft_server.jar:git-Spigot-1496]
   at net.minecraft.server.v1_7_R3.MinecraftServer.run(MinecraftServer.java:489) [minecraft_server.jar:git-Spigot-1496]
   at net.minecraft.server.v1_7_R3.ThreadServerApplication.run(SourceFile:628) [minecraft_server.jar:git-Spigot-1496]


Sometimes, it comes up with this in rapid succession, usually resulting in a bit of server slowdown.


I'm running spigot MC version 1.7.9 build 1496. I can give the running plugins if needed as well[

Offline Demo

  • Owner/Co-Founder
  • *****
  • Posts: 787
Re: 1.5.5 minor issue/bug
« Reply #1 on: July 20, 2014, 11:57:40 PM »
Will get this looked at by our Minecraft Coding Team.
Appreciate the post :)

Offline jcbjoe

  • Jr. Member
  • **
  • Posts: 6
Re: 1.5.5 minor issue/bug
« Reply #2 on: July 29, 2014, 11:17:19 AM »
Hello,
Sorry for the long reply to this post. I looked into the plugin and I have found that the place that the error was coming from was a old debug method that the old developer used. It was a chat event which may have been the reason for your lag. I have now removed this event and debug method and uploaded a new jar file here: https://www.dropbox.com/s/9cy581onqd1qc2z/hive365.jar Please test it again and if you have any more problems be sure to reply back :)


Thanks,
Joe

Offline jcbjoe

  • Jr. Member
  • **
  • Posts: 6
Re: 1.5.5 minor issue/bug
« Reply #3 on: July 29, 2014, 09:49:33 PM »

Offline Mody

  • Newbie
  • *
  • Posts: 2
Re: 1.5.5 minor issue/bug
« Reply #4 on: August 01, 2014, 10:49:18 PM »
Hey jcb!


Thanks for the updated version of the plugin, i've tested it and it seems to be running just fine. All features and commands run smoothly without any errors coming up in the logs, and without any noticeable performance nuances.


Really appreciate the effort you put into developing and maintaining the plugin, thanks again :)